Delayed ACH Transactions

Incident Report for LoadPay

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 20:32 UTC

Investigating

Customers may have trouble adding / removing ach accounts. ACH payments newly created will be delayed until the outage is resolved.
Posted Sep 04, 2025 - 19:49 UTC
This incident affected: Website.